AWSのアカウントセットアップの「クラウドアカウントの連携」ステップにおいて、CloudFormationの作成が「ROLLBACK_IN_PROGRESS」となる場合があります。主に考えられる原因とそれぞれの対処法を説明します。
状況把握
AWSの「CloudFormation」>「スタック」>「SafingStack」>「イベント」 ページからロールバックが起こったイベントを確認することができます。そのイベントの「状況の理由」からロールバックとなった原因を確認します。
原因
考えれる原因は以下のように大きく分類されます。
リソースの重複
CloudFormationが作成しようとしたリソースがすでに存在していることが原因です。
過去にスタックを作成したことがあり、そのスタックによって作成されたリソースが残ってしまってる場合に発生する可能性があります。
実行ユーザーの権限
CloudFormationのスタック作成の実行ユーザーの権限が制限されていることが原因です。
CloudFormationのSafingスタックを作成するための権限が実行ユーザーに足りていない場合に発生します。
リソースの実行権限
CloudFormationで作成しようとしたリソースに対する実行権限が制限されていることが原因です。
以下の可能性が考えられます。
- ご使用のAWSアカウントにおいて、Safingが情報を収集するためのIAMロールを作成する権限が制限されている可能性があります。AWS Organizations SCPなどで制限されていることにより発生することが多くあります。
- ご使用のAWSアカウントにおいて使用不可能なリージョンを設定している可能性があります。
対処方法
「実行ユーザーの権限」、「リソースの実行権限」に該当する場合
1. Safingのクラウドアカウント設定を確認する
「クラウドアカウント設定」の以下の項目に間違いがないか確認し、ある場合は情報を修正してください。特にリージョンは
- リージョン
- Inspectorバージョン
2. AWSアカウントの設定を確認する
実行ユーザーは管理者権限で行うことを推奨します。
リソースの実行が制限されている場合は、AWSアカウントの管理者にお問い合わせの上、制限緩和をご検討ください。サポートが必要な場合は、Safing Consoleの「サポート」よりSafingサポートチームにお問い合わせください。
3. 再セットアップの実行
原因が解消されたら、Safing Consoleの「クラウドアカウント設定」>「設定をやり直す」より「再セットアップ」を行います。
最初のステップで「設定済のスタック削除」があります。実行に失敗したスタックを削除します。
次のステップで「クラウドアカウントの連携」があります。CloudFormationのスタックを作成しなおします。
作成に成功した場合は、画面の指示に従って次のステップに進んでください。
作成中、再び問題が発生した場合は原因解消を行ったのち手順をやり直してください。問題が解消できない場合はSafing Consoleの「サポート」よりSafingサポートチームにお問い合わせください。
「リソースの重複」に該当する場合
1. 作成されるリソースがすでに存在していないか確認し「SafingStack」を削除する
AWSの「CloudFormation」>「スタック」>「SafingStack」>「イベント」 >「状況の理由」からロールバックとなったリソースを確認します。リソースの存在するAWSサービスページでリソースの存在確認を行った後、CloudFormationの「SafingStack」スタックを削除してください。「SafingStack」スタックにより作成されたリソースはスタックの削除によって削除されます。
2. ロールバックとなった原因のリソースが残っている場合はリソースを直接削除する
スタックを正常に削除した後もロールバックとなった原因のリソースが存在する場合は、リソースの存在するAWSサービスページより、Safingとの連携によって作成されたリソースであるか、削除しても問題ないかを確認してください。
確認して問題ないと判断できた場合はリソースを削除してください。Safingとの連携によって作成されたリソースの場合、「SafingStack」スタックによって再度作成されますので削除して問題ありません。
3. 再セットアップの実行
原因が解消されたら、Safing Consoleの「クラウドアカウント設定」>「設定をやり直す」より「再セットアップ」を行います。
最初のステップで「設定済のスタック削除」があります。実行に失敗したスタックを削除します。上記手順ですでに削除している場合はスキップしてください。
次のステップで「クラウドアカウントの連携」があります。CloudFormationのスタックを作成しなおします。
作成に成功した場合は、画面の指示に従って次のステップに進んでください。
作成中、再び問題が発生した場合は原因解消を行ったのち手順をやり直してください。問題が解消できない場合はSafing Consoleの「サポート」よりSafingサポートチームにお問い合わせください。